cannot access any file when using sshfs mount a directory in windows sftp server

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I will appreciate if someone can help me out of this:

I am running a sftp server on windows XP ( I have tried both freesshd
and "Core FTP mini-sftp-server"). I use sshfs on gentoo linux to mount
a directory from the sftp server. Here is the command:
$sshfs user@windows_box_ip:  /mnt/sftp/

Everything works fine so far, and the sftp server is mounted. But when
I run
$ls -al /mnt/sftp
It shows:
ls: cannot access /mnt/sftp/test.log: Input/output error
drwxrwxrwx 1 root root    8 Dec 31  1969 .
drwxr-xr-x 7 root root 4096 Sep 19 04:51 ..
drw-rw-rw- 1 root root    0 Sep  5 15:27 Temp
drw-rw-rw- 1 root root    0 Sep 18 14:50 USB_HANDY_TOOL
drw-rw-rw- 1 root root    0 Aug 28 16:07 WorkNoteBook
drw-rw-rw- 1 root root    0 Sep  5 10:10 development
?????????? ? ?    ?       ?            ? test.log

Basically all files are not accessible in this case, which makes the
mount meaningless.

I guess it may related to windows file permission setting is not
understood by linux machine, but same thing happens to the directory
in FAT and FAT32 partition. Also network mounting should hide the
details of those filesystem inplementation specific issues.

Can anyone tell me how to solve this?


Site Timeline