Can't connect from Putty v0.55 to Foundry switch with SSH

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I've run into a problem with Putty and Foundry switches.  I've been
using Putty with my Cisco routers without any issues.  I then
configured a Foundry switch (as per Foundry's configuration guide) and
after I type in my name followed by my password, Putty tells me access
denied and then asks for the password again.

Looking at the Foundry logs the password sent from Putty was correct
and the switch authenticated me.  I tried SecureCRT 3.3 without
changing any settings on the Foundry switch and I was admitted to the
command prompt.

I've tried several versions of Putty .53, .54, .55, including the
Development release as of 8/24/2004 with no luck.

I also created a public/private key pair using puttygen and configured
the client appropriately, but Putty came back and told me that the key
was invalid (back to a logon and password combination which still
didn't work).

Has anyone else been successful at configuring Putty to logon to a
Foundry FastIton Edge 4802 switch with SSH?  The codeset on the
Foundry is 03.0.00Tc1.  Your assistance is extremely appreciated.


Re: Can't connect from Putty v0.55 to Foundry switch with SSH

Quoted text here. Click to load it

Judging by
you need to enable the "Chokes on SSH1 ignore messages"
bug-compatibility mode (see
< ).

(Normally PuTTY attempts to guess whether to enable bug compatibility
modes by the version string, but in the last report we had, the Foundry
device's version string was too similar to that of other, non-buggy

Quoted text here. Click to load it

I can't explain this behaviour, though (I don't think PuTTY will use
SSH_MSG_IGNORE packets during SSH-1 public key authentication, although
I haven't checked).

Site Timeline