Building OpenSSH 4.3p2 on Solaris 10

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I've hit a brick wall trying to build OpenSSH 4.3p2 on Sol 10 (x86).

I've already built OpenSSL 0.9.8a in /usr/local/openssl, but no matter
what I try, the configure script of OpenSSH ends with the dreaded message:

checking OpenSSL header version... 90801f (OpenSSL 0.9.8a 11 Oct 2005)
checking OpenSSL library version... 90704f (OpenSSL 0.9.7d 17 Mar 2004)
checking whether OpenSSL's headers match the library... no
configure: error: Your OpenSSL headers do not match your library.

configure is called as so:

configure --prefix=/usr/local/openssh-4.3p2 --with-ssl-dir=/usr/local/openssl

My OpenSSL happens to be a 64bit ELF for AMD64. By default openssh builds
to 32bit, but adding --build=amd64-pc-solaris2.10 makes no difference.

appropriately but the configure script stubbornly insists on finding the in /usr/sfw/lib rather than the one in

I've even tried moving the Sol1 0 out of the way, but the
configure script still doesn't find the one I've built.

The script doesn't find the openssl lib I've built either,
though it does find the header files.

I can't build openssh against the Solaris 10 libcrypto because of the
lack of the 192 and 256 bit DES functions.

I'd be very grateful of any suggestions for solving this.

Liam Gretton                Leiden, The Netherlands

Re: Building OpenSSH 4.3p2 on Solaris 10

Quoted text here. Click to load it
Quoted text here. Click to load it

Try ./configure --with-cflags=-m64 or build a 32-bit OpenSSL and use

Darren Tucker (dtucker at
GPG key 8FF4FA69 / D9A3 86E9 7EEE AF4B B2D4  37C9 C982 80C7 8FF4 FA69
    Good judgement comes with experience. Unfortunately, the experience
usually comes from bad judgement.

Re: Building OpenSSH 4.3p2 on Solaris 10

On Fri, 24 Mar 2006, Darren Tucker wrote:

Quoted text here. Click to load it

That's it, thanks.

I found the log, which indicated it didn't like the 64bit libs.
There are too many dependencies on 32bit libs to be able to build a 64bit
openssh at the moment, but it seems my 32bit OpenSSL build isn't working,
so I'm pursuing that.

Thanks again.

Liam Gretton                    Leiden, Netherlands

Site Timeline