Secure Shell Forum - Main Page

Have a question or want to show off your project? Post it! No Registration Necessary.  Now with pictures!

Secure Shell Forum -all implementations of Secure Shell (SSH) network protocol, inclusing OpenSSH are discussed here
Web, RSS and Social Media interface to
There are 15153 individual articles here that are part of 4163 discussions
Please see below the list of the most recent and the best rated articles in Secure Shell Forum

The most recent discussions

ssh on command line: force using a group size (prime size) of 1024 (and not...

October 22, 2016, 9:41 am

Hi Is there a way to make ssh use prime size of 1024, i.e. Not sending SSH2_MSG_KEX_DH_GEX_REQUEST(1024 Read more »

protocol question - issue with exit-status inside unfinished data stream?

October 10, 2016, 8:46 pm

Hi list, I am using a Java library (ganymed ssh2) to connect to a remote server usin g a terminal session. This has worked fine for years, but since a few month s I get intermittent errors where a... Read more »

openssh pausing for 10 sec before connecting

October 8, 2016, 4:41 pm

I am having trouble with openssh connecting from my laptop to a remote computer via ssh, in that it is taking about 10 sec to connect. If I do ssh -vvv remote I get two pauses, one about 8 sec a... Read more »

AES-CBC mode in OpenSSH

October 6, 2016, 6:51 pm

In OpenSSH 5.2 release notes it says there are mitigations to to CPNI-95703 7 Plaintext Recovery Attack Against SSH, but in the latest release of Ope nSSH 7.3, AES-CBC is disabled. Should AES-CBC ... Read more »

SSH+LDAP problems

September 23, 2016, 4:18 pm

Hello everyone. I'm Ricardo from Costa Rica. I am trying to set up a server with LDAP authentication (via SSH). I have tried the same configuration on 2 other servers, one with CentOS6.5 and anoth... Read more »

ssh remote forwarding with loopback ips

September 18, 2016, 9:59 am

Hello, Having at sshd_config: GatewayPorts yes With, and ips configured at lo interface and configured sshd on localhost and executing next from localhost: ssh -R 1... Read more »

Strange ssh 'attacks?'

September 8, 2016, 2:36 pm

I am getting whole masses of lines like the following in my ssh logs on a Mageia Linux machine. What do they mean? How can I get rid of them? sshd[1908]: Received disconnect from 11... Read more »

ssh tunneling hang

September 5, 2016, 4:24 pm

Hello, I installed 0.67 Release of putty on a Windows 8.1 laptop. Set up is following, working well with ssh client under Linux. Autossh from a Linux customer server to our Linux server: it open po... Read more »

fast windows scp?

August 25, 2016, 7:09 am

Can anyone recommend a Windows scp program? I tried Putty's pscp and the O penSSH for Windows at Both are too slow. On gigabit Ethernet with half-millisecond ping, pscp transfer... Read more »

Why is PermitLocalCommand set to 'no' by default?

August 18, 2016, 7:31 pm

Reading ssh_config manual, I discovered local commands and PermitLocalCommand being set to 'no' by default. Then I started to wonder how PermitLocalCommand set to 'yes' could be a security risk. 1.... Read more »

PuTTY Storing Host Keys in Windows Registry

August 16, 2016, 7:53 am

Hello, I have a question regarding PuTTY, which is stemming from a problem I am facing at the moment. I am writing a Python program using the modules paramiko and pysftp. These modules are lookin... Read more »

What is default mapping between Kerberos user principle instances and syste...

August 6, 2016, 6:48 am

I am looking for any information regarding Kerberos user principle instances. It's principles in format username/instance@REALM. Instance has different password from main account username@REALM. I ... Read more » putty has trojans?

July 25, 2016, 11:47 pm

I had to rebuild my workstation over the weekend and went to snag a current copy of jakub kotrla's putty build. Firefox fought me tooth and nail to keep me from going there and downloading the zip... Read more »

Three hop socks proxy

June 20, 2016, 8:29 am

Hi All, I've got this: At home I have my windows laptop running mobaxterm (=cygwin). From windows I ssh into bastion1 (=solaris 5.8) From bastion1 I ssh to bastion2 (=solaris 5.10) From bastion2... Read more »

PuTTY/plink: Supplying public keys to second and subsequent hops on multiho...

June 15, 2016, 11:09 pm

I have been trying to set up a transparent multihop link through a bastion host to a destination in a remote network that does not accept connections from outside its ownnetwork. The intention is to... Read more »

Intsalling OpenSSH 7.2p2 server on SunOS 5.11 (Solaris 11.3)

June 10, 2016, 2:27 am

My apologies in advance if this has been asked and answered. I'm trying to update OpenSSH on Solaris 11.3. Oracle sells the updates. We are a free/open source project with no budget, so purchasing s... Read more »

Intermittent failure on remote ssh echo command with exist status 143 (aka ...

May 17, 2016, 3:29 pm

I use remote ssh echo command as heartbeat to probe remote server is alive. After days of running, I get an intermittent ssh exit status 143 (143 - 128 = 15 ) which is SIGTERM. The remote echo comma... Read more »

How to check forwardings

April 10, 2016, 11:31 am

Assume I have openedo shared connection to server, and I executed some ssh -O forward .... statements how can I see which ports are forwarded and where? KJ -- Read more »

PuTTY 0.67 is released

March 5, 2016, 8:55 am

PuTTY version 0.67 is released ------------------------------ All the pre-built binaries, and the source code, are now available from the PuTTY website at Read more »

Not signing in

February 17, 2016, 4:18 pm

I hope that someone can direct me to a solution. When I tried to login to p utty, it came up showing Fatal Error - connection time out. I tried and t ried to login and do password, but when putty s... Read more »

Click here for other recent discussions »

The best rated discussions



Hi, I can only assume there is a very good reason why PAM messages of the above classes only get output by SSH AFTER the PAM auth stack has been finalized. I have found discussion of this topic a... Read more »


Intsalling OpenSSH 7.2p2 server on SunOS 5.11 (Solaris 11.3)

My apologies in advance if this has been asked and answered. I'm trying to update OpenSSH on Solaris 11.3. Oracle sells the updates. We are a free/open source project with no budget, so purchasing s... Read more »


PuTTY version 0.61 is released

PuTTY version 0.61 is released ------------------------------ All the pre-built binaries, and the source code, are now available from the PuTTY website at Read more »


No option for saved sessions in pageant

I have ran into a peculiar issue with Pageant not detecting any sessions i have set up in putty. When right clicking on pageant its only options is view/add keys about and exit. No option for saved s... Read more »


reverse ssh - why connection refused?

I shall maintain the linux server of a relative which has a internet connection through a gsm router. This router is unable to open incoming ports that's why I try to establish a reverse SSH tunnel... Read more »


DatacenterManager is SSH Heaven!

You've got to check out this Awesome java tool: Read more »


Rename files with scp?

-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1 I'm trying to develop an application where remote sites can scp files into a directory on my system and I pick them up for processing. I'd like to scp ... Read more »


openssh 6.6 disallows passwordless login if home directory allow group writ...

I am running openssh 6.6p1 on a Mageia 5 machine. For some reason my home directory got its mode changed to rwxrwx--- with group root. openssh then disallowed passwordless login to that machine (... Read more »