Problems with Stunnel, Freecap, and Tor

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Hi guys!  First time poster here, please don't kill me :-D

Okay.  Gist of it is this.  I've been trying to set things up so that my
usenet usage is "anonymized."  I picked up a FAQ that gives a pretty good
how-to on that, using Stunnel, Freecap, and Tor.

Now, I'm kinda new to network security.  I'm an old hat at personal computer
security, but networks have always left me lost and slightly confused.  Lets
see if I've got this right;  I need to set things up so that my newsreader
communicates through Stunnel, which encrypts my data.  After that, Stunnel's
output goes through Freecap, thus preparing it for use with Tor.  Tor takes
it and routes it through a whole bunch of servers and crap, and eventually
(so the theory goes) the data comes out somewhere way off from where I am,
encrypted (with Stunnel) and then travels to my news service.  If that's
right, then I guess I learned something :-P

Well, the thing is this.  I've been able to set up Stunnel to serve as a
bridge between my newsreader and my newsservice, and I follow the steps in
the FAQ exactly for configuring Stunnel to work through Freecap and Tor, but
whenever I start Stunnel from Freecap, it gives me this error

Error resolving '': Neither nodename nor servname known (EAI_NONAME)

Now, I've got no clue where it's getting from.  That address isn't
in my stunnel.conf file at all, so there's no clues there.  For the life of
me, I just can't figure this out on my own.

Could anyone possibly give me a hint as to what I'm doing wrong?

Site Timeline