xampp installation

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I installed basic xampp with the installer from
http://www.apachefriends.org/en/xampp-windows.html#524 .

When I started Apache from the panel, I got a window with the error
   This application has failed to start because php_mbstring.dll was
not found. Re-installing ...

I tried to re-install but it did not help.

I found in the web references to this problem but everything that they
suggest is already correct at my php.ini: definition of extension_dir
and php_exif.dll appears after mbstring.

In the control-panel - the status of Apache is running and the start
button was replaced by a stop button.

Apache and PHP are new for me.


Re: xampp installation

Quoted text here. Click to load it

did you install apache as a service? filzilla/mysql all should be
services unless you have a need for them not to be.
if they are use services.msc to check on the status of apache mysql
and filezilla, ignore the control panel, in my experience - which isnt
much, is that it lies. if the application failed to start, then it
failed to start no matter what some gui says.
are you editing the right php.ini file? that in apache/bin directory,
have you added any lines to xampp from a website, or is it default -
are you running php as a module. If you did add lines did you add the
reference to the wrong module, if you are running apache 2.2.x are you
using the php for apache2.2.x dll?
did you check that php_mbstring.dll actually does exist? If you can
download the latest dll from the php (pecl) website for your version
of php.
did you have a preiexisting setup which you have tried to install over
the top of, perhaps there are config or files still hanging around
from before?

Re: xampp installation

Quoted text here. Click to load it
No. Must I?

 filzilla/mysql all should be
Quoted text here. Click to load it
I assume that this is not the reason for the php error on Apache

Quoted text here. Click to load it
When I clicked start in the control-panel - an apache.exe process
appeared in the processes table and that error message. When I clicked
OK on the error-window a similar error appeared for OCI.dll, then for
several other dll. After the last error-message - a second apache.exe
appeared in the processes table. Are there supposed to be two

When I direct the browser to http://localhost I get an empty page.
When I direct it to http://localhost:8080/ I get an error message.

Quoted text here. Click to load it

Yes, the default.

Quoted text here. Click to load it
I just started it from the panel.

Quoted text here. Click to load it
The file exists.

Quoted text here. Click to load it

Also, which book and which online manual can you suggest me to read in
order to study Apache?


Re: xampp installation

Quoted text here. Click to load it

hmm! well the only thing I would suggest is have a look at the php.ini
in xampp/apache/bin rather than the one in xampp/php/ you might see in
that php.ini that the settings which are correct in the xampp/php are
not repeated, thi s is what i think it is. The one in php folder is
for command line work.

well i use the online manual for apache, and if you're using firefox
just type
"apache 2 docs mod_rewrite" and you will get the link to mod_rewrite,
its a great site actually, couple that with alt.apache.configuration
and you're there.
I would recommend not running to much xampp stuff at first as its
rather insecure and bulky, and install as services means that
everything starts when your computer does, no hassle.

THere should indeed be two apache processes on windows, one is the
child process that does all the work.
php is set to show errors on startup, which is why you get a whole
load of pop ups, useful for debugging, but I can say that xampp is
very very stable, its likely to be the wrong php.ini file,

In fact IMHO there should be two but the command line one should be
named php-cli.ini for clarity.

Re: xampp installation

Quoted text here. Click to load it
When in xampp - "diff apache/bin/php.ini php/php.ini"  shows that they
are identical.

After I start Apache and I get those error messages, I browse to :
http://localhost/                  and get an empty page
http://localhost/index.html   and get a page with the text "it works"
http://localhost:8080           and get an error message

does it mean that apache is running and I only have some php problem?

Quoted text here. Click to load it

Re: xampp installation

Quoted text here. Click to load it
You get an error using port 8080, which is Tomcat right, so there are
issues there. But I cant think why you are having problems loading the
dlls for php I am afraid unless the dlls are not matched with the
version of the apache module or something liek taht which can happen.

Site Timeline