Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I want php.ini in my own place, say /etc not default /usr/local/bin.
So when I configure I use --with-config-file-path=/etc .... Easy !?
It dose not work, well it configure, make and make install ok but still
looking for php.ini in /usr/local/bin.
A script with phpinfo() tells me it looks in /etc but it still php.ini from
Using: Slackware 10.1, Apache 2.0.54, PHP 5.0.4

Re: --with-config-file-path

On Thu, 19 May 2005 07:06:15 +0000, GunFro wrote:

Quoted text here. Click to load it

I have the same version of PHP and it works for me:

Configure Command      './configure' '--with-apxs2=/opt/apache/bin/apxs'
'--with-zlib' '--with-gd' '--enable-gd-native-ttf'
'--with-config-file-path=/usr/local/lib/php' '--with-oci8' '--enable-sigchild'
'--without-sqlite' '--disable-mysql'
Server API     Apache 2.0 Handler
Virtual Directory Support     disabled
Configuration File (php.ini) Path     /usr/local/lib/php/php.ini

I am on FC3.
Demagogue: One who preaches a doctrine he knows to be untrue to
           men he knows to be idiots.
H.L. Mencken

Site Timeline