What point am I missing?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I don't know if I can explain what is happening but I will give it a try.

I have 2 pages that display a set of thumbnail and they are almost
identical.  The only difference is the text file they point to that
holds the picture information.  I have a php script that reads the text
file and lays out the thumbnails and creates a link to a page that shows
the full image.  The first thing the html file does is open a session so
I can store some information that the full size page needs.  I type the
url in for the first thumbnail page and it works perfect and goes to the
full size page and back perfect.  When I click the link to the other
thumbnail page it can't find the text file and it looks like it can't
find the .css file and other files.  If I type the exact same link in
for the second page it works fine.  The url's are identical but if I
type it in it works if I go to it through a link it doesn't work.  I am
pretty stumped by this.  I figure it must have to do with the sessions
but I don't know.  At first I was not destroying the sessions so added
that but it acted just the same.


Re: What point am I missing?

from Will contained the following:

Quoted text here. Click to load it

And neither will we without seeing the code..  Have you considered
passing the information in the URL instead of using sessions?
Geoff Berrow (put thecat out to email)
It's only Usenet, no one dies.
My opinions, not the committee's, mine.
Simple RFDs http://www.ckdog.co.uk/rfdmaker /

Re: What point am I missing?

Geoff Berrow wrote:
Quoted text here. Click to load it

It is amazing what a good night's sleep will do.  I worked on this
problem for over 2 hours yesterday and could not figure it out.  I was
going to put up the site so you could see and I noticed that the urls in
the links ended with a /.  Once I removed that then everything worked
fine.  I wouldn't have thought the / at the end of a url mattered but I
have never put one there before so I guess I would have never seen this
before.  If you still want to look it is at www.wholcomb.com/bookcases.php .


Re: What point am I missing?

Thanks for the URL....I'm a little disapointed, though.  From reading
the OP I thought for sure you were building a porn site.

Site Timeline