Upgrading php

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I currently have php 4.1.2 on a Raq 4 server (apache / linux) and want
to upgrade it to 5. Can sombody point me to the correct docs on how to
do this?

Bill H

Re: Upgrading php

Bill H wrote:
Quoted text here. Click to load it


You may need to do a clean install.


Re: Upgrading php

Bill H wrote:
Quoted text here. Click to load it

It depends on which version of Linux you're running.  I suggest you
check your Linux's support forums.

Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.

Re: Upgrading php

Quoted text here. Click to load it

You may want to go through your distro's package management system,
but if you want control over the compilation, you might want to grab
the source.

Make sure to back up your existing php.ini and httpd.conf
configuration files.  IIRC, running `make install' will attempt to
alter httpd.conf, if it can find it.

Next, make sure to carefully read the PHP FAQ[1] about migrating from
4 to 5.

In the FAQ, they mention the PHP 5 migration appendix[2], so make
sure to look over that document as well.  For the most part, PHP 5
does a very good job with backward compatability.

[1] <http://www.php.net/manual/en/faq.migration5.php
[2] <http://www.php.net/manual/en/migration5.php

Anonymous (1984 IOCCC winner):
int i;main()"];read('-'-'-',i+++"hell\
o, world!\n",'/'/'/'));}read(j,i,p)

Site Timeline