Upgrade php 4.3.6 to 5.2.4 ??

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Kimmo Laine wrote:
Quoted text here. Click to load it

Unless next_page.php generates PHP, the script with this include will
only get HTML.

Quoted text here. Click to load it


    if (isset($_GET['foo'])) {
      echo '<?php echo $_GET[\'foo\']; ?>';
    } else {
      echo '<?php echo \'Not available\'; ?>';

File not found: (R)esume, (R)etry, (R)erun, (R)eturn, (R)eboot

Re: Upgrade php 4.3.6 to 5.2.4 ??

On Sep 20, 4:06 pm, jerryyang_...@yahoo.com wrote:
Quoted text here. Click to load it


I did just that two days ago. are you using IIS or apache?

I'm using apache, so all i needed to do was download the php 5.2.4 zip
from the php website, unzip it and replace the old php directory that
i had.

 Dont delete the old php directory until you have the new install
working. Rename your current install to something like php_old or
something. and rename the new install with the name of the old one, in
the same location.

You will then have to reconfigure the new php.ini file in the new
install. Open the php directory, make a copy of the file php.ini-
reccommended and rename it to 'php.ini'.

Open it in a text editor and find the line

extension_dir = "/."

change this to the path of the 'ext' folder in your php directory (you
could use the setting from your old php.ini file since you have just
replaced the old directory with the new one it will be the same)

Load the extensions that you want by uncommenting them in the php.ini
folder, such as mysql etc


Open the file httpd.conf in your apache/conf directory and add this,
(but change the paths to match your install) and remove the one that
was for your php4 install.

LoadModule php5_module "C:/webserver/PHP/php5apache2.dll"
AddType application/x-httpd-php .php

# configure the path to php.ini
PHPIniDir "C:/webserver/PHP"


restart your webserver and bob's your uncle!

If you are using IIS, sory cant help there beyond saying - use apache,
it's miles better!



Re: Upgrade php 4.3.6 to 5.2.4 ??

Thanks Paul

I'm using IIS !!
Think I can sort that bit.

Since posting this it looks like SquirelMail may not like PHP 5.x.x

So I may be better sticking with 4.x.x for now.

Think I'll have a play and see what happens :)


Site Timeline