Upgrade OpenSSL version = rebuild PHP?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I just learned that the version of OpenSSL I'm running (on a RedHat EL)
server has some vulnerabilities that I'd like to close. I'm running PHP
5.1.4. My question is this: I've got PHP 5.1.4, and it's built with
"--with-openssl=shared" in the ./configure command line. If install the
latest version of OpenSSL, do I need to relink PHP?

Site Timeline