unable to load dynamic library php_mcrypt.dll.. error

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I am getting the error "unable to load dynamic libray php_mcrypt.dll...". I
understand that php_mcrypt.dll depends on the existence of libmcrypt.dll
library. I am using Windows 2003 and I have downloaded two versions of this
dll and installed them once in php's ext folder and Windows's system32.

The question is why am I still getting this error? Why are there different
versions of libmcrypt.dll around while there's no version info in the dll?
Also why isn't libmcrypt.dll distribued with php_mcrypt.dll?
At least the PHP folks should mention where we can get it and what version
goes with what.

I had to comment the extension entry in php.ini file because it's unusable.

John Dalberg

Site Timeline