ubuntu php5 xml support

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I have been trying to use php5's xml support.
My OS is Ubuntu 5.10
I am running apache2 with php5, no problems there.

I installed the php5-xsl package but when I use any xsl related
functions in my php, I get errors like:
"Call to undefined function xslt_create();"

I have played around with installing a bunch of other packages that
might be remotely related, but my (limited) understanding of how the
ubuntu package management system worked was that the dependancies were
handled automatically.

And yes, I did do
Quoted text here. Click to load it
to restart the apache server.

I have also looked at
it contains the following line at the end of the file (I didn't add the
line, it must have been done automatically)

phpprint(); outputs the following:
XSL     enabled
libxslt Version     1.1.15
libxslt compiled against libxml Version     2.6.20
EXSLT     enabled
libexslt Version     1.1.15

Any assistance would be much appreciated!
Thank you for your time.

Site Timeline