Ubuntu php4-pgsql Fix

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I found some strange kind of mild install bug when installing Ubuntu
5.04 php4-pgsql module (the module that connects PHP4 to PostgreSQL).
You may encounter the error:

Call to undefined function: pg_connect()

No amount of using Synaptic Package Manager would fix this for me. The
solution was all at command line under 'root' account:

$ apt-get update
$ apt-get install php4-pgsql
$ /etc/init.d/postgresql restart
$ /etc/init.d/apache2 restart

Site Timeline