trouble with php5 ( while phpmyadmin works)

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

J have installed php5 with the rest of the tools on debian wheezy LAMP.
the phpmyadmin works properly, suggesting that all tools are properly confi=
I launched  localhost/myphpadmin I received the correct page and I connecte=
d without problem.

But  if I put any command for example the famous phpinfo () in a file teste=
r.php, I place this file in the root /var/www or in a personal directory (I=
 comment out the lines that it must be in the module mod_php to activate th=
e home directory, anyway the problem remains the same in the root)
Php is  not executed!!?? if I put this file in the directory of phpmyadmin =
it runs!!

2 or 3 years ago,  I  used the same procedure,  the php/apache2 worked.

I guess there's a new data in the latest version of php or apache2.

thank you for your help

Re: trouble with php5 ( while phpmyadmin works)

On Thu, 25 Oct 2012 02:18:42 -0700, abelahcene wrote:

Quoted text here. Click to load it

grep -i documentroot /etc/apache2/apache2.conf
grep -i documentroot /etc/apache2/sites-enabled/*


Denis McMahon

Re: trouble with php5 ( while phpmyadmin works)

Am 25.10.2012 11:18, schrieb
Quoted text here. Click to load it

What does this mean exactly about commented lines? If you removed the PHP
configuration, put it back.

What does "Php is not executed" exactly mean? If you see the PHP source in the
browser, it would be clearer to say so.

Does your script habe the necessary <?php tag?


Site Timeline