The mbstring PHP extension was not found... using iis

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I use win 2000, php 4.4.2, phpmyadmin, iis 5.0, and mysql 5.0.

When I try to run http://localhost/phpmyadmin/index.php I get the error


The mbstring PHP extension was not found and you seem to be using a
multibyte charset. Without the mbstring extension phpMyAdmin is unable
to split strings correctly and it may result in unexpected results.

PHP Warning: Unknown(): Unable to load dynamic library
'c:\php\ext\php_mbstring.dll' - The specified module could not be
found. in Unknown on line 0


The file c:\php\ext\php_mbstring.dll exists. php ini has extension_dir
= "c:\php\ext\" and extension=php_mbstring.dll.

What am I doing wrong?


Jan Nordgreen

Re: The mbstring PHP extension was not found... using iis

damezumari wrote:

Quoted text here. Click to load it

Hi Jan,

Should work...
Check for a few possible mistakes, like:
1) Are you edditing the right php.ini?
Call phpinfo() to see what php thinks the right php.ini is.
(Sounds stupid, but you wouldn't be the first or the last who  
2) call phpinfo(), and check if PHP agrees that you loaded the module.
It SHOULD be named somewhere.
3) Is the ddl readable for the IUSR_<machinename> ?

If that doesn't help, come back here.

Good luck.


Re: The mbstring PHP extension was not found... using iis

Hi Erwin,

Thanks for your reply!

I was editing the right php.ini. I believe the problem was that I used
php_mbstring.dll from php 5 and not 4.4.2.

I also copied libmysql.dll to c:\winnt\ from

Now it works!


Jan Nordgreen

Site Timeline