Stuck With Oracle

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I have SuSE 9.1, Apache2 and PHP installed.  I want to use it against an
existing Oracle database on the same server, but when SuSE installs PHP, it
is only with mysql support.

I am reading that I need to recomplile PHP with "--with-oci8" option.  SuSE
does not have the PHP source on their website, just the binaries.  Does this
mean that I have to wipe clean my PHP and Apache install, download the
source, and recompile it?

I am not an advanced Linux user so this sounds daunting to me.  Is there
another way around it?  I was reading that I might just be able to put a
line for Oracle similar to "" in my /etc/php.ini file.  Of
course I would need the Oracle .so from somewhere.

Any help would be appreciated.  I don't relish the thought of starting over.

Re: Stuck With Oracle

Quoted text here. Click to load it

Yes, go to the php site, download the source, and build it from scratch.

Quoted text here. Click to load it

Hire someone.

DeeDee, don't press that button!  DeeDee!  NO!  Dee...

Site Timeline