Somewhat bizarre PHP5/Apache startup dilemma

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hi folks.  Either I'm missing something really obvious (most likely) or
I'm missing something really subtle.  I've been building up a machine
as an IMP webmail server, with php 5.1.2, cyrus-sasl, openldap, imap,
fileinfo, mod_perl, sqlite, horde, Berkeley DB and PostgreSQL, among
others, on top of an old Potatoe machine that was already alive and in
production so I just went with it.  Everything worked great up until
the installation of fileinfo, which I abruptly decided to install after
everything else was up and running and Horde's test.php screen was
already up and displaying features.

At that point (after installing fileinfo with PECL) Apache 1.3.34
bailed on me, refusing to start (or restart) with no error message
whatsever.  I can't find a trace of an error message in either Apache's
logs or any of the system logs.  If I comment out PHP's LoadModule and
AddModule lines in my httpd.conf, Apache starts just fine.  If I
uncomment them, Apache refuses to start.  "Apachectl start" comes back
and says that httpd is up and running, but "ps -aux" doesn't show any
Apache processes.  I had initially started with the latest stable
snapshot of PHP, but I blew away /usr/local/lib/php and reinstalled
5.1.2 just in case that was the problem, with identical results.

Somewhere on this system is file that's poisonous, I think, but what
gets me is that I don't even get any error logs.  Does anybody have any
ideas for troubleshooting?

Thanks in advance!

Re: Somewhat bizarre PHP5/Apache startup dilemma

voronwae wrote:
Quoted text here. Click to load it
What do your LoadModule and AddModule lines look like?

Silly question:
You are using "ps -aux | grep httpd" right?

Can you run echo "<?php phpinfo(); ?>" | php from the command line?


Re: Somewhat bizarre PHP5/Apache startup dilemma

Kimmo Laine wrote:
Quoted text here. Click to load it

Unless next_page.php generates PHP, the script with this include will
only get HTML.

Quoted text here. Click to load it


    if (isset($_GET['foo'])) {
      echo '<?php echo $_GET[\'foo\']; ?>';
    } else {
      echo '<?php echo \'Not available\'; ?>';

File not found: (R)esume, (R)etry, (R)erun, (R)eturn, (R)eboot

Re: Somewhat bizarre PHP5/Apache startup dilemma

voronwae wrote:
Quoted text here. Click to load it

I'll dig some more but my Linux box has these in modules not libexec.
Any chance you got the directory wrong?


Re: Somewhat bizarre PHP5/Apache startup dilemma

Thanks again, David.  The directory's right, and the files exist.  I'm
using Apache 1.3.34, though.

You've reminded me that I haven't tried to run a perl script.  Huh.
Maybe I'll try that as a test.  I predict it will work okay, though.
Apache doesn't seem to care whether libperl is in the configuration


Re: Somewhat bizarre PHP5/Apache startup dilemma

Perl works just fine, and I'm still bamboozled.  I've discovered that
Apache 1.3 doesn't reload its configuration files if I just restart it,
but if I stop the process, it gives me a friendly "/usr/sbin/apachectl
start: httpd started" and then promptly dies without even a logged
gasp.  You'd think one would at least get a goodbye left somewhere
where it might eventually be found.  I have all the logging I can find
turned on in php.ini.  It may be time to download the Apache source and
pepper it with printfs.  Google just found me a post from someone else
last year who had similar problems on his FreeBSD box but had
everything up and running on a Windows box in under fifteen minutes.
Highly demoralizing.


Site Timeline