Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I try to connect my php-soap-client to a https-webservice("https://
xxxxxxx?wsdl"), but it doesn't work.

I tried these possibilites:

1.) $client = new SoapClient("https://xxxxxxx?wsdl");
-> SoapClient-ERROR: " SSL operation failed with code 1. OpenSSL Error
messages:error:140770FC:SSL routines:SSL23_GET_SERVER_HELLO:unknown
protocol, Failed to enable crypto, Could not connect to host"

2.) $client = new SoapClient("https://xxxxxxx?wsdl",
cert_key.pem is the server-certificate of https://xxxxxxx
-> SoapClient-ERROR: "Unable to set local cert chain file
`cert_key.pem`; Check that your cafile/capath settings include details
of your certificate and its issuer"

When I try to call the webservice in a browser, then I am asked to
accept the server-certificate. When I accept, everything works fine.
How can I force my soap-client to accept this server-certificate
(automatically)? Does the soap-client expects the certificate of the
server or my client-certificate. I've read a post about this subject
here ( ), but don't
understand it. I can't imagine that the soap-client really expects the
private key of the server.....

Or is there a possibility to configure php (or the webserver) to
accept certain certificates or to accept all certificates?

Thanks for any help

Site Timeline