simple PHP 5.1 (Windows XP) build issue with Libxml - fatal error C1083

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I am trying to obtain more debugging information for an issue I
reported (ref. Bug #37185
< ). Unfortunately, I do not
have access to the now-ancient Microsoft Visual C++ 6.0, which is why I
cannot use the pre-built debug sysbol files for debugging. So it
appears I must build PHP. I grabbed build php5.1-200605011630 earlier
today, but am having build problems.

My environment is
Windows XP SP2, IIS 5
Visual Studio 2005
I am trying to follow the instructions in

There is a cryptic comment part of the way down:
Before starting, be sure you have read Abschnitt namens Putting it all
together and you have built all needed libraries, like Libxml or ICU
(needed for PHP >= 6).
I have read the preceding instructions, and I am not building PHP >= 6.
I did not see any earlier reference to Libxml or ICU though. I am not
sure where to grab the right version of Libxml from, or what steps I
should follow to make it visible to Makefile after that. Undeterred, I
continued, and of course failed.

Specifically, when I try and run nmake, part way through, I have a
fatal error:
h:\work\php5.1-200605011630\ext\dom\php_dom.h(33) : fatal error C1083:
Cannot open include file: 'libxml/parser.h': No such file or directory
NMAKE : fatal error U1077: '"E:\Program Files\Microsoft Visual Studio
8\VC\BIN\cl.exe"' : return code '0x2'

My thanks in advance to anyone who can help me find the right files and
place them in the right path for Makefile.

Site Timeline