shell symbols and exec problem

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I have a problem running following shell command from php exec or
system call:
exec("/bin/cat $(/bin/cat list.txt) > concatenated.txt"). This works
when i run it directly from the shell as user nobody (apache user), so
its not a path/permissions problem.
Basically list.txt contains a list of filenames, which are to be read
and concatenated into one big file (concatenated.txt).
I have even tried writing a shell script, wrapping this command, and
tried running it, but still no result. The script either way just
writes an empty concatenated.txt.
Any advice appreciated! :)

Re: shell symbols and exec problem

new guy wrote:

Quoted text here. Click to load it

Just an idea: Give the whole path to concatenated.txt might help.

Erwin Moller

Re: shell symbols and exec problem

try using full pathes and maybe telling it what shell should be used
may help

Site Timeline