Problem with PHP upgrade

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Hello group!

The configuration:
Windows, PHP 4.4.3, MySQL 5.0.24

I'm trying to upgrade PHP 4.4.3 to 5.1.6. I've installed and configured
everything but there is a problem with my db applications on PHP - the
UTF8 characters appear as "?". Apache, PHP and MySQL are fully (and
correctly, I think) configured for UTF8 support and it worked on the
old PHP, but now it just can't display the UTF8 characters (cyrillic in
this case), although the configuration is almost the same. I tried to
use mysqli instead of mysql, but it seems that it won't provide the
functions for MySQL that I need.

I tried to modify the configuration of PHP5 but it seems that the UTF8
MySQL support is really broken. The built in MySQL support in PHP4
worked like a charm, but in PHP5 it's an external module which makes
many problems. I think about downgrading php_mysql.dll to an older
version or recompiling PHP5 with built in MySQL support. Any ideas? Can
the problem be in libmySQL.dll? Thanks in advance!

Site Timeline