problem using FPDF

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hi every one
I'm trying to use fpdf
but when I use the first  Tutorials in /
this error massage is show
Strict Standards: date() []: It is not safe to rely on
the system's timezone settings.
Please use the date.timezone setting, the TZ environment variable or
the date_default_timezone_set() function.
In case you used any of those methods and you are still getting this
warning, you most likely misspelled the timezone identifier.
We selected 'Europe/Moscow' for '3.0/no DST' instead in C:\AppServ\www
\try\fpdf153\fpdf.php on line 1363

Warning: Cannot modify header information - headers already sent by
(output started at C:\AppServ\www\try\fpdf153\fpdf.php:1363) in
C:\AppServ\www\try\fpdf153\fpdf.php on line 1022
FPDF error: Some data has already been output to browser, can't send
PDF file


Re: problem using FPDF

Quoted text here. Click to load it

Edit that line and put a drop-dead sign (@) in front of it. It will keep

Willem Bogaerts

Application smith
Kratz B.V. /

Re: problem using FPDF

Willem Bogaerts wrote:

Quoted text here. Click to load it

Bad man. Very bad! Thats for real not a acceptable solution.

Simple adding this code will point him to a better solution:


He must place it before hes including the fpdf-Lib, oor better hes
setting date.timezone within php.ini to the value.

A php error notice is not a joke and must be also handled by a correct way.

So long, Ulf

Re: problem using FPDF

Quoted text here. Click to load it

So what's the difference? That is relying on a setting which is not bad
anyway. If I explicitly want to pass a time zone, I do so. If I want to
configure a different one, I do so as well. The date function just
should not fail for perfectly ordinary requests. So alas all date
functions have to be silenced. That is the bug. Not the fact that I am
relying on something perfectly harmless.


Re: problem using FPDF

Dikkie Dik wrote:
Quoted text here. Click to load it

Ulf is correct.  Adding the '@' is just hiding a problem.  It's better
to fix the problem.

The warnings are real and important.  The bug is that you're relying on
something which is not reliable.  If you want to use the date functions,
you need a valid time zone.

Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.

Site Timeline