Problem Making php 4.3.8

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Forgive me, this is probably a very simple problem, but it's new to
When I attempt to make php 4.3.8, it exits, and I believe the relevant
message is:

libtool: link: cannot find the library `'

I suspect it may be a problem with the Makefile, but more likely, I
have failed to configure php correctly. Here's the configure command I

 ./configure --enable-versioning --enable-memory-limit
--with-layout=GNU --enable-force-cgi-redirect --enable-discard-path
--enable-fastcgi --with-openssl --with-zlib --enable-bcmath --with-bz2
--enable-calendar --with-crack --with-curl --with-cyrus --with-db4
--with-inifile --enable-dio --with-dom --enable-exif
--with-zlib-dir=/usr/lib --with-dom-xslt --with-dom-exslt
--enable-exif --enable-ftp --with-gd --with-gettext --with-gmp
--with-hyperwave --with-iconv --with-imap --with-imap-ssl
--enable-mbstring --with-mcal --with-mcrypt --with-mcve
--with-openssl-dir --with-mhash --with-mime-magic --with-ming
--with-mnogosearch=/usr/local --with-mysql --with-pspell
--enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm
--with-zip --with-apxs

I'd be grateful for any help anyone can provide.

Re: Problem Making php 4.3.8

Befuddled wrote:

Quoted text here. Click to load it

I had a similar problem when I was trying to make php from a path with
special characters like SPACE, ', "", etc. but I don't remember which
one exactly, was many years ago...

"Cosa sono i milioni, quando in cambio ti danno le scarpe ?"

Re: Problem Making php 4.3.8

Befuddled skrev:
Quoted text here. Click to load it

1) you haven't specified a dir to --with-openssl-dir.
   I know that ./configure --help describes it as optional, but in my
   experience it's not
2) try disabling/enabling the directives in groups to find the one
   that's giving you trouble

Bjarne D Mathiesen             /
København N ; Danmark ; Europa
denne besked er skrevet i et totalt M$/Intel-frit miljø
MacOS X 10.3.4 Panther ; Mozilla 1.7rc1+ ; PowerPC G4 800MHz

Site Timeline