PHP4 PHP5 under Apache 2.0

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I just cleaned my comp, and I am trying to re-config my webserver...

I am trying to setup apache 2 so it runs both php4 and php5, I also
have two instances of mysql running.  I know this can be done cos it
had work before, but after this incident its not longer...

These are my directories for each:

Apache:  D:\ServerRoot\Apache\Apache2
MySQL1:  D:\ServerRoot\mysql1
MySQL2:  D:\ServerRoot\mysql2
PHP4:    D:\ServerRoot\php4
PHP5:    D:\ServerRoot\php5
DocumentRoot: D:\FTPRoot

Why am I using two sql you may asked? Well, I have one for every
database of mine, and the second one is just for email database, in
case something happens.

This is what I don't want to do, having to move the dlls into the
windows directory.

I am using XP.

I did a loadmodule php5_module D:/ServerRoot/php5/php5apache2.dll and
one for php4 also

but I usually get this error back:
PHP Startup: Unable to load dynamic library
"d:\serverroot\php5\ext\dllfile.dll" - The Specified module could not
be found.

I know its in there cos I looked in there.

Another Error I get is:
Unknown(): (null): Unable to initialize module
Module compiled with module API=20041030, debug=0, thread-safety=1
PHP Compiled with module API=20040429, debug=0, thread-safety=1
These options need to match
犝    0AHope that is enough information.

Site Timeline