php webservice extensions on IIS, IIS returns 404 on php

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I'm trying to get the PHP isapi filter to work on IIS.

as per the manual
I have done the following:
"#  If you don't want to perform HTTP Authentication using PHP, you
can (and should) skip this step. Under ISAPI Filters, add a new ISAPI
filter. Use PHP as the filter name, and supply a path to the
php4isapi.dll / php5isapi.dll.
# Under 'Home Directory', 'Virtual Directory', or 'Directory', do the
# Change the Execute Permissions to 'Scripts only' "

and then
"Click on the 'Configuration' button, and choose the Application
Mappings tab. Click Add and set the Executable path to the appropriate
ISAPI DLL. An example PHP 5 value is: C:\php\php5isapi.dll
Supply .php as the extension. Leave 'Method exclusions' blank, and
check the 'Script engine' checkbox. Now, click OK a few times."

That seems to already be done.

"#  Stop IIS completely (NET STOP iisadmin)
# Start IIS again (NET START w3svc) "

have done so several times by now

"With IIS 6 (2003 Server), open up the IIS Manager, go to Web Service
Extensions, choose "Add a new Web service extension", enter in a name
such as PHP, choose the Add button and for the value browse to either
the ISAPI file (php4isapi.dll or php5isapi.dll) or CGI (php.exe or php-
cgi.exe) then check "Set extension status to Allowed" and click OK."

since I have IIS 6 this is probably what I want to do, I guess, but
when I do this it comes with a tooltip over my path to the dll that

This file is already required by PHP: Hypertext Processor.

so what should I do to get around the Windows IIS return 404 on php


Re: php webservice extensions on IIS, IIS returns 404 on php

Quoted text here. Click to load it

I don't think the ISAPI filter works unless you have IIS set up (try
Web.config) to handle PHP files through the filter. Set it up as you
would set up any filter.

-Mike PII

Site Timeline