php_mysql.dll fails to load

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I have apache2, mysql  4.0.21 and php 5.0.2.on xp pro.

All works fine up to the point where I enable the php_mysql.dll module
in php.ini. I followed the instructions and copied libmysql.dll to
c:\windows, also modified the "extension_dir" to point to
c:\sqlphp\php\ext which works fine as the error message I get shows the
proper path for php_mysql.dll file. Also, I checked it out to see if the
file is there and it is indeed in that directory.

Here is the error message:
PHP Warning:  PHP Startup: Unable to load dynamic library
'c:\sqlphp\php\ext\php_mysql.dll' The specified module could not be
found. In Unknown on line 0

So far, I did a search on the internet and other people who had the same
problem seem to say that by moving libmysql.dll and php_mysql.dll to
\windows or \windows\system32 the problem would be sorted. Unfortunately
for me, tried it and it doesn't work, i get the same message. I even
tried to register the dlls manually using regsrv32 and even that failed.

By the way, I get this message when I start php from the command line. I
had to disable apache2 as it falls over as soon as it tries to load the
php module which in turn tries to load the php_mysql.dll module. Also,
Apache2 reports the same error before crashing, so for the time being I
disabled the service.

I would appreciate any help on this issue as it starting to drive me mad.

Many thanks

Re: php_mysql.dll fails to load

Thanks, it has been sorted.

Alex Popescu wrote:

Quoted text here. Click to load it

Site Timeline