php compile informix error ifx_checkAPI

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I am trying to use PHP 5.0.4 on Solaris 9 (Sparc) with SDK 2.81.UC3 or SDK
2.90FC1.  When I fire up httpd I get the following error:

Cannot load /usr/apache/libexec/ into server: httpd: fatal: r
elocation error: file /u/informix/lib/esql/ symbol ifx_checkAPI: ref
erenced symbol not found

I found a reference about the Informix CSDK:

If the API version of the libraries in this executable file are not compatible,
ESQL/C returns a runtime error that indicates which library is not compatible.
You must recompile your ESQL/C application to link the new release-version of
the shared library.
If you do not use esql to link one of the shared Informix general libraries with
your ESQL/C application, you must explicitly link the checkapi.o file with your
application. Otherwise, ESQL/C might generate an error at link time of the form:

undefined ifx_checkAPI()

So how do I tell the configure script to link the correct checkapi.o?

Gary Quiring

Re: php compile informix error ifx_checkAPI

Quoted text here. Click to load it
I have manually linked the checkapi.o file and still get the same error.  Anyone
got this working?


Site Timeline