PHP 5.0.1 and Apache2

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I followed all the steps described in the manual of PHP to install PHP 5.0.1
with Apache (even went to recompile the apache server) but when I try a PHP
script, I only see the code. Checked everything in the FAQ about this, but
nothing seems to work :'(

Does anyone has an idea how to solve this?

Re: PHP 5.0.1 and Apache2

What OS? If this a new installation or an upgrade from a previous version?
Have you had PHP + Apache working on that machine before?

We cannot help you with your problem unless you supply proper details.

Tony Marston

Quoted text here. Click to load it

Re: PHP 5.0.1 and Apache2

Tony Marston wrote:

Quoted text here. Click to load it

Indeed, what have you done precisely? Have you added the proper lines to
  the httpd.conf file?


The most likely way for the world to be destroyed,
most experts agree, is by accident.
That's where we come in; we're computer professionals.
We cause accidents.
                    --Nathaniel Borenstein

Re: PHP 5.0.1 and Apache2

Hello again

Ok, here we go:

OS => Mandrake Linux 10.0 Community Edition

Yes, Apache 2 was installed on the computer, but removed it before
reinstalling it from scratch. Installed it like said on (manual)
with the options: --enable-so

After install and test of Apache, installed php with options like in manual
(--with-apxs2=/usr/local/apache2/bin/apxs --with-mysql)

All went nice, copied the php.ini file to /usr/local/lib/ (used the
recommended and the distri one) and added the AddType and LoadModule (though
the PHP5 module was in /usr/local/apache2/modules/ so I put
modules/libphp5 in the LoadModule part.

Checked all the different options with httpd and all seems working (mod_so.c
is loaded)

If any more information is needed, please reply ;)

Quoted text here. Click to load it

Re: PHP 5.0.1 and Apache2

Thierry Vael wrote:
Quoted text here. Click to load it

You need to tell apache what to do with .php files u need to add the line:

AddType application/x-httpd-php .php

to your httpd.conf, just stick it with the other Add Type commands

Site Timeline