PGSQL 7.4.8 PHP 4.3.4 & Apache 2.0.49 Segmentation Fault with Client Certs

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

Having an issue that is specific to PHP compiled with PGSQL support
with versions noted in subject line.  I understand that there are many
variables to consider here but believe I have narrowed down the Apache
Client Cert failures to my PHP/PGSQL build.
1.  Apache PHP without PGSQL works as expected using client
2.  Apache PHP with PGSQL works fine with standard SSL connections
3   Apache PHP with PGSQL fails with client certificates - no output
other than Segmentation faults in the apache error logs as follows:
[Wed Nov 30 23:26:57 2005] [notice] suEXEC mechanism enabled (wrapper:
[Wed Nov 30 23:26:58 2005] [notice] Apache configured -- resuming
normal operations
[Wed Nov 30 23:27:05 2005] [notice] child pid 4065 exit signal
Segmentation fault (11)
[Wed Nov 30 23:27:06 2005] [notice] child pid 4066 exit signal
Segmentation fault (11)

I also performed same tests on another instance of Apache/PHP/PGSQL
which was version 2.0.54 of apache and PHP/PGSQL versions same as
subject line with same exact results.

Any ideas as to the source of this problem and suggestions for
tests/fixes are greatly appreciated.  There are no errors in any of the
logs other than what I have included so it's very difficult to see what
is wrong.  All I know for sure is that I am able to reproduce the
results on more than one machine.  The switch that kills everthing is
SSLVerifyClient require
SSLVerifyDepth 1                     on in the apache configuration.


Paul Valentino

Re: PGSQL 7.4.8 PHP 4.3.4 & Apache 2.0.49 Segmentation Fault with Client Certs

Still having same problem - any pointers for generating more output to
help isolate problem greatly appreciated.

Site Timeline