Permissions problem

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
How do I get past a "...permission denied..." error condition?

I'm running PHP 5.2.5 with IIS 5.1 on Windows XPPro with all service
packs and updates. FWIW, this is an intranet-only setup.

PHP itself seems to be working in that I display the PHPInfo page.

I have a page that starts off by doing a session_start(). It's
generating a "Permission denied (13)..." error on the folder where
it's trying to write the session cookie (or at least I think that's
what it's trying to do).

What guidance I've been able to find by Googling, tells me to
right-click on the folder, select properties and then select the
"Security" tab. Well, there is no "Security" tab; there is a "General"
tab, a "Sharing" tab, a "Web Sharing" tab and a "Customize" tab. I've
poked around on all of those and have not been able to find anything
that would allow me to change the permissions on that folder.

I read something that said this permissions stuff has to be set from
within IIS. They also specified going to certain tabs on certain
windows (in IIS) - none of which actually exist on my system.

Can someone possibly point me to some instructions that actually work
in the environment that I'm working in (as noted above)?


Re: Permissions problem

Fred wrote:
Quoted text here. Click to load it

Try a Windows newsgroup.  You'll get better help there.

Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.

Re: Permissions problem


Quoted text here. Click to load it

You should upgrade your IIS to a newer version or turn it off and use
Apache.  If you have no choice, go to the MSDN site and look up the
settings for your version of IIS.  You need to specify which
directories are "visable" and at what permission level.  Your reading
that the settings are to be made within IIS.

gburnore at DataBasix dot Com
                    How you look depends on where you go.
Gary L. Burnore                       |  ۳ݳ޳ݳۺݳ޳ݳݳ޳ݳ۳
                                      |  ۳ݳ޳ݳۺݳ޳ݳݳ޳ݳ۳
Official .sig, Accept no substitutes. |  ۳ݳ޳ݳۺݳ޳ݳݳ޳ݳ۳
                                      |   0 1 7 2 3 / ݳ 3 7 4 9 3 0 ۳
Black Helicopter Repair Services, Ltd.|     Official Proof of Purchase

Re: Permissions problem

Quoted text here. Click to load it

Have you set up the path it should write a cookie to? If so, does it exist?

Quoted text here. Click to load it

Allthough this is sent from a Windows computer, I have very little  
experience setting up webservers from that platform. However, user  
experience on Windows tells me that you'll have to disable simple file  
sharing, and use a proper user/group file sharing(/file permission) system  
to be able to set the desired security settings on a folder (which most  
likely would involve both making the guest account(or whatever IIS runs  
as) a valid account and giving it write priviliges). The combination  
IIS/user accounts is beyond my experience though, as most of this  
particular medium (servers OS's tend to be Linux/BSD), so if you run into  
troubles even with simple file sharing off, asking in an IIS group (as  
it's the webserver that needs write priviliges, not PHP per se) might  
prove more usefull.
Rik Wasmus

Re: Permissions problem

On Sat, 16 Feb 2008 04:54:19 +0100, "Rik Wasmus"

Quoted text here. Click to load it

Thank you! Thank you! Thank you!

Yes, I was using simple file sharing. When I turned that off, the
"Security" tab showed up. That enabled me to set up the IUSR account
with the proper attributes.

Now it works !!!

Thanks again.

Site Timeline