memory_limit doesn't work on OS X?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I'm trying to get TYPO3 working with the built-in PHP and Apache on OS X
Server 10.3.4, and the installer complains that memory_limit is set too
low in php.ini. However, raising it seems to have no effect. What can I
do? Is this a limit of the pre-installed PHP?

Changes to, for instance, upload_max_filesize in the same file are
recognized, so I know I'm editing the right thing.

"I want to thank my friend, Sen. Bill Frist, for joining us today.... He married
a Texas girl, I want you to know. (Laughter.) Karyn is with us. A West Texas
girl, just like me."
                       -- George W. Bush in Nashville, Tenn., May 27, 2004

Re: memory_limit doesn't work on OS X?

ZnU wrote:
Quoted text here. Click to load it

This is probably a bug in the TYPO3 installer.

The pre-installed PHP doesn't have the memory limit option compiled in
(at least the version on Panther client doesn't) so a check for
ini_get('memory_limit') returns an empty string "" no matter what is in
php.ini. If the installer doesn't expect this it may be interpreting it
as a value of 0, which is less than the minimum it wants.

-- brion vibber (brion @

Site Timeline