Loaded Configuration File (none) ? Why ?

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I compiled PHP 5.2.5 from source, and configured as follow :
'./configure' '--sysconfdir=/etc/php' '--enable-debug'
'--enable-magic-quotes' '--with-openssl' '--with-zlib' '--with-bz2'
'--enable-calendar' '--with-curl' '--with-gdbm' '--enable-ftp'
'--with-gd' '--with-gettext' '--with-mcrypt' '--with-mhash'
'--enable-zip' '--with-kerberos'
'--with-apxs2=/usr/local/apache2/bin/apxs' '--with-mysql'
'--with-config-file-path=/etc/php' '--with-xsl' '--enable-shared'
'--with-curlwrappers' '--enable-zip' '--enable-exif' '--enable-mbstring'

i used the config-file-scan cause i would, in the future, use a per
virtual host/per directory php configuration.
But for the moment, i'm unable to load any configuration file...
I specified --with-config-file-path=/etc/php and cp the
php.ini-recommend into it and the ls command returns :
drwxr-xr-x 2 root root  4096 2008-02-14 15:15 more
-rw-r--r-- 1 root root   962 2008-02-15 02:05 pear.conf
-rw-r--r-- 1 root root 48618 2008-02-14 13:50 php.ini
So php should be able read the file...
I can't understand why the php.ini file is not being read...

Any ideas ?

BTW : how could i load different php.ini in my virtual directory and use
(what i suppose being to do) --with-config-file-scan-dir=/etc/php/more
I check php documentation but wasn't able to find a solution to just
give the configuration file to load...


PS : debian etch, apache 2.2, php 5.2.5

Re: Loaded Configuration File (none) ? Why ?

Quoted text here. Click to load it

Nothing immediately springs to mind - have you tried accessing the
file from within your own php code?

Quoted text here. Click to load it

You can override most settings from the ini file within your Apache
config - see http://us2.php.net/configuration.changes but I think you
need PHP5.3 to change the ini file used.


Site Timeline