Installing PHP / Apache problems (again)

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I have had to reinstall windows and at present I am currently trying to
put back in place my apache2/php4 setup.

I have installed apache and I get the http://localhost 'apache is
installed' page. Nice one!

When I try to configure apache with PHP unzipped into a folder (c:/php)
and run it as a module, no matter what I try it just wont load the PHP
page in 'htdocs'. I havent yet set it to automatically load
'localhost/index.php' when you simply type in 'localhost', so when I do
this is presents me with a page with the file contents of localhost.
index.php is there but when I click it I then get a 404 error.

I had originally put a post up before which I think worked for me then,
but not now.

I have tried the following httpd.conf settings:

ScriptAlias /php4/ "C:/php/"
AddType application-xhttpd-php .php
Action application-xhttpd-php "/php/php.exe"

Im no expert on Apache so when something like this happens Im kinda
stuck. I searched on Google but it appears there are so many different
ways of installing php on apache.

Any ideas?


Re: Installing PHP / Apache problems (again)

On 22/08/2005 23:59, wrote:


Quoted text here. Click to load it

Remove the '4' from the URL-path in the ScriptAlias directive, or add it  
to the cgi-script argument of the Action directive ("/php4/php.exe").

Be aware that you might also need to allow access to the C:/php/  
directory with a Directory directive. See the cgi-bin alias, for example  
(search for: ScriptAlias /cgi-bin/).


Hope that helps,

Michael Winter
Prefix subject with [News] before replying by e-mail.

Site Timeline