installed and still no go

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hello Group,
I have installed via pecl using the following commands:
$ pecl install pdo (this seemed to do all the things it was supposed to
  then I entered the following command: $ pecl install pdo_mysql (this
seemed to be ok as well)
it placed the .so files in a dir

both the and the files were there. (tried copying
them into /usr/local/apache2/lib/php/extensions/ )

I am using fedora core 6, apache 2.2, and php 5.2 and mysql 5.027.
when I try to open a connection to the database, i still get a "driver
not found" error.

the pdo_mysql name does not show up in my phpinfo() page, if I run it.
I have added the "" etc in my php.ini file.

What am I still missing?  do I have to reconfigure php??

any info will help,



Re: installed and still no go

Quoted text here. Click to load it

Did you stop and restart apache?

Re: installed and still no go

Hello Gordon --
stop and restart apache as well.
New sympton - rebuilt PHP 5.2 with sqlite as shared, and noticed that
the code, as php was building,
did seem to pick up the dir for the and files.

Now my error message is:  Fatal error: Class 'PDO' not found in
/usr/local/apache2/htdocs/display_pets.php on line 63

my code to call PDO is:
$db = new PDO('mysql:host=localhost;dbname=menagerie',$dbuser,$dbpass);

I am open for suggestions!



Gordon Burditt wrote:
Quoted text here. Click to load it

Site Timeline