Installation errors...

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View

I'm trying to install a local copy of php5 and not having much luck. I want
LIBXML and IMAP support. When I go to configure php (no matter what options
I use) I end up with the error message...

<start quote>
Configuring extensions
checking whether to enable LIBXML support... yes
checking libxml2 install dir... /usr/home/MYACCOUNT/libxml
configure: error: libxml2 version 2.5.10 or greater required.
<end quote>

I want LIBXML support so I downloaded and tried to install it...I get as far
as "nice make install" when I get the following error message...

<start quote>
MYACCOUNT@% nice make install \
--prefix=/usr/home/MYACCOUNT/libxml \
--exec-prefix=/usr/home/MYACCOUNT/libxml? --prefix=/usr/home/MYACCOUNT/libxml
? --exec-prefix=/usr/home/MYACCOUNT/libxml
Making install in include
Making install in libxml
make install-exec-hook
/usr/local/bin/bash ../../mkinstalldirs /usr/local/include/libxml2/libxml
test -z "/usr/local/include/libxml2/libxml" || mkdir -p --
/usr/bin/install -c -m 644 'SAX.h' '/usr/local/include/libxml2/libxml/SAX.h'
install: /usr/local/include/libxml2/libxml/SAX.h: Permission denied
*** Error code 71

Stop in /usr/home/MYACCOUNT/libxml/include/libxml.
*** Error code 1

Stop in /usr/home/MYACCOUNT/libxml/include/libxml.
*** Error code 1

Stop in /usr/home/MYACCOUNT/libxml/include.
*** Error code 1

Stop in /usr/home/MYACCOUNT/libxml.
<end quote> you can see I'm trying to install it locally by using
"--prefix=/usr/home/MYACCOUNT/libxml" as I read in the help file but it
still wants to use "/usr/local/include/libxml2/libxml" and I obviously don't
have permission for that folder...

What do I do?

My server uses Apache & FreeBSD 4.8

John MacLeod

Re: Installation errors...

John MacLeod wrote:
Quoted text here. Click to load it

I don't have experience building LIBXML, but did you run the configure  
script before trying to make it?
Usually configure scripts also allow you to specify an install prefix.



Re: Installation errors...

Thanks were right...I needed to include the path when running  
the configure script not during the "nice make install"..

.so now I seem to have gotten it configured and installed, but I'm having a  
problem using the .htaccess file to point the local installation of php5. As  
per the instructions I was following I added the following to the .htaccess  

<start quote>
#PHP 5.0.5 FINAL without security wrap
Action application/x-httpd-phpx /cgi-bin/php5.cgi
AddType application/x-httpd-phpx php php3 phtml php4 php5
<end quote>

...but when I run the sysinfo.php test script I get the following error...

<start quote>
Not Found
The requested URL /cgi-bin/php5.cgi/horde/sysinfo.php was not found on this  
<end quote>

...I'm searching for another web page about this but haven't found anything  
yet. If anyone can help it would be greatly appreciated.


Quoted text here. Click to load it

Site Timeline