https wrapper

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

We're running PHP4.3 on a Solaris 9 box. PHP was compiled with the
following option:


phpinfo() suggests that openssl is enabled. However, when we try to use
fopen with an https:// URL we receive the following message:

[24-Oct-2008 14:20:12] PHP Notice:  fopen(): Unable to find the wrapper
"https" - did you forget to enable it when you configured PHP?
in /u1/www/htdocs/f.php on line 8
[24-Oct-2008 14:20:12] PHP Warning:  fopen( /):
failed to open stream: No such file or directory in /u1/www/htdocs/f.php
on line 8

"" is our intranet site, which runs Apache with the same
version of OpenSSL as PHP is using.

Has anyone else encountered this problem? I'm wondering if we need to
enable something in php.ini but a bit of googling seems to suggest that
it should just work...

Site Timeline