Help with Lighttpd PHP PATH_INFO support...

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

In the course of playing with my new Lighttpd
server, I ran into a problem with the PHP_SELF, PATH_INFO, and
ORIG_PATH_INFO variables - specifically, Lighty doesn't provide them to

my PHP install. Now, this isn't specifically a PHP issue, but so far no
one in the Lighty community has come up with a good fix for this -
short of doing without PATH_INFO.

Even after applying all the fixes I could find:

Adding "broken-scriptfilename" => "enable" to my PHP config in

Set cgi.fix_pathinfo = 1 in /etc/php4/cgi/php.ini

Compiled PHP4 with ./configure --enable-fastcgi --with-ldap
--with-mysql --enable-force-redirect --enable-discard-path

Nothing works. A successful answer is one which, when applied to the
webserver hosting this, causes the PATH_INFO and related variables to
be filled correctly.

Below is some partial relevant output from my php and
lighttpd config:
Quoted text here. Click to load it
Configure Command      './configure' '--enable-fastcgi' '--enable-ftp'
        '--with-mysql' '--enable-force-redirect'

_SERVER["SCRIPT_NAME"]    /test/info.php
_SERVER["PATH_INFO"]    no value
_SERVER["SCRIPT_FILENAME"]    /var/www/test/info.php
_SERVER["DOCUMENT_ROOT"]    /var/www/
_SERVER["REQUEST_URI"]    /test/info.php
_SERVER["QUERY_STRING"]    no value

Quoted text here. Click to load it
fastcgi.server = ( ".php" => ((
                     "bin-path" => "/usr/local/bin/php",
                     "socket" => "/tmp/php4.socket",
                     "broken-scriptfilename" => "enable"

Site Timeline