Disallow "HTTP chunked" transfer !

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hi !

Yesterday, I posted a topic regarding to XML problem that I've been
having. The old topic can be found at:

Thanks to Álvaro G. Vicario for pointing out "chunked" transfer thing.
Anyway, I tried to avoid "chunked" transfer in HTTP protocol. I have
looked at "transfer-encoding" on the web, but it doesn't help much.
What value/variable should I specify in HTTP request to ask the server
not using "chunked" transfer ?

If anyone experienced this problem/ know how to do this, please share
your thought. Any help would be greatly appreciated.


Lazy Pig (Josh)

Re: Disallow "HTTP chunked" transfer !


Quoted text here. Click to load it

 HTTP/1.1 clients _must_ be able to accept and decode chunked transfer
encoding. If you are making an HTTP/1.1 request to fetch the data, then its a
bug in your code if you do not handle it. Are you doing raw requests using
fsockopen() etc.?

 Some options:

(1) Implement chunked transfer encoding decoding.
(2) Use a library that implements this for you, rather than rolling your own
HTTP client (e.g. cURL, or PHP fopen wrappers).
(3) Make HTTP/1.0 requests instead.

Andy Hassall :: andy@andyh.co.uk :: http://www.andyh.co.uk
http://www.andyhsoftware.co.uk/space :: disk and FTP usage analysis tool

Re: Disallow "HTTP chunked" transfer !

Hi Andy,

Thanks a lot for your response. My code works when I use HTTP 1.0 Raw
request with fsockopen.

Lazy Pig

Andy Hassall wrote:
Quoted text here. Click to load it
Quoted text here. Click to load it
ts a

Site Timeline