Compiling PHP5 - Can't write module

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!


I'm trying to install php5 as a shared module for Apache 2 (on SuSe 10.0). When I compile I don't get I don't know why, I'm not getting any errors, there are a few warnings, but they all deal with the Zend engine (they are mostly arguments differ in signedness).

My configure is:
./configure --with-apx2=/usr/local/apache2/bin/apxs

I compiled Apache 2.0.55 with the following configure:
./configure --prefix=/usr/local/apache2

Did I screw something up or miss something? I read somewhere online (wish I had bookmarked it) that it won't write without I checked /lib and /usr/lib for it and it doesn't appear I have it. Is it needed? If so, where can I find it (or how can I install it)? I tried apt-get, but it didn't work. I couldn't find anything relevant in the PHP FAQ either. :(

Any help would be greatly appreciated.


Site Timeline