Compile PHP4 with SNMP

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I tried to compile my php 4.3.9 with snmp support but it won't work.
Compiling Net-SNMP always worked good --> I tried the 5.2rc4 and also the
older version 5.1.2 successfully so far. I use Fedora Core 2.

Here's what I already tried with php (Every configure options version listed
below was tried with both of the two snmp versions):

../configure --with-openssl --with-apxs=/usr/local/apache/1.3.31/bin/apxs --w
ith-mysql=/usr/local/mysql/4.0.20/ --with-zlib --with-gd --enable-versioning
 --enable-track-vars=yes --enable-url-includes --enable-sysvshm=yes --enable
-sysvsem=Yes --with-config-file-path=/etc --with-ldap --with-snmp && make &&
make install

I also tried without openssl
and I tried with: --disable-cli --disable-pear (using these php would
compile correctly but trying to restart apache wouldn't work)

Here's my error message:

Build complete.
(It is safe to ignore warnings about tempnam and tmpnam).

Installing PHP SAPI module:       apache
[activating module `php4' in /usr/local/apache/1.3.31/conf/httpd.conf]
cp libs/ /usr/local/apache/1.3.31/libexec/
chmod 755 /usr/local/apache/1.3.31/libexec/
cp /usr/local/apache/1.3.31/conf/httpd.conf
cp /usr/local/apache/1.3.31/conf/
rm /usr/local/apache/1.3.31/conf/
Installing PHP CLI binary:        /usr/local/bin/
Installing PHP CLI man page:      /usr/local/man/man1/
Installing PEAR environment:      /usr/local/lib/php/
/root/php-4.3.9/sapi/cli/php: error while loading shared libraries:
/root/php-4.3.9/sapi/cli/php: undefined symbol: usmAES192PrivProtocol

make[1]: *** [install-pear-installer] Error 127
make: *** [install-pear] Error 2

Hope anybody can help,

Site Timeline