Cannot load php_mcrypt module (php_unregister_ini_entries missing)

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
I need to load php-mcrypt.dll when starting up Apache with PHP loaded
as a module.

I have these lines in my Apache http.conf:
(at end of LoadModule section)
LoadModule php4_module c:/php_4_2_0_win32/sapi/php4apache.dll

(at end of AddModule section)
AddModule mod_php4.c
AddType application/x-httpd-php .php

Apache comes up fine with other PHP extensions preloaded (like zlib,
bz2, etc), but when I try mcrypt it does not.

In my php.ini I have "extension=php_mcrypt.dll" (in addition to dlls
for zlib, bz2, etc) and the dll is present in the windows systems32

When I try to start Apache it says,

"The procedure entry point php_unregister_ini_entries could not be
located in the dynamic link library php4ts.dll", followed by "Unable
to load dynamic library ./php_mcrypt.dll. The specified procedure
cound not be found."

Indeed, the dll file does not have such a function. How do I fix this?

My configuration is Apache 1.3.24, PHP 4.2.0 running on Windows XP.


Re: Cannot load php_mcrypt module (php_unregister_ini_entries missing)

I believe you need libmcrypt.dll aswell, most likely in the same directory
as your PHP CGI module

Take a look at:

All the destructions you need are there.



Quoted text here. Click to load it

Re: Cannot load php_mcrypt module (php_unregister_ini_entries missing)

I get the same error messages with or without libmcrypt.dll in my
windows system32 folder. I went over to the link below but couldn't
find answers.

Another thing I found was "php_unregister_ini_entries" is in
php_mcrypt.dll, and it complains about not being able to find this dll
-- I tried copying it to the folder that has my php4apache.dll, still
no help.

Don't know what this all means.

Thanks anyway,

Quoted text here. Click to load it

Re: Cannot load php_mcrypt module (php_unregister_ini_entries missing)

Quoted text here. Click to load it

I remember reading the user notes when I was setting mine up, someone
mentioned that the current version of libmcrypt.dll didn't work for them so
they tried an "old" version which worked fine. I found completely the
opposite to be true.

My libmcrypt.dll is sitting in C:\PHP along with php-cgi.exe
The php_mcrypt.dll is in C:\PHP\ext

Uncomment ;extension=php_mcrypt.dll in your php.ini

The last stage for me was to add C:\PHP\ext (or whatever your extension
directory is) to the PATH variable.

Try that. :)

Site Timeline