apxs problem when updating PHP

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hope someone can point me in the right direction to fix this one...

I'm currently running Apache 2.0.40 and PHP 4.2.2 on a RedHat9 server.
I'm needing to update to PHP5 but don't want to change the way the rest
of the server is configured. So far I've done the following...

1. Copied the following from phpinfo to get the current configuration...

'./configure' '--host=i386-redhat-linux' '--build=i386-redhat-linux'
'--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr'
'--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin'
'--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include'
'--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var'
'--sharedstatedir=/usr/com' '--mandir=/usr/share/man'
'--infodir=/usr/share/info' '--cache-file=../config.cache'
'--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d'
'--enable-force-cgi-redirect' '--disable-debug' '--enable-pic'
'--disable-rpath' '--enable-inline-optimization' '--with-bz2'
'--with-db3' '--with-curl' '--with-dom=/usr' '--with-exec-dir=/usr/bin'
'--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-gd'
'--enable-gd-native-ttf' '--with-ttf' '--with-gdbm' '--with-gettext'
'--with-ncurses' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr'
'--with-openssl' '--with-png' '--with-pspell' '--with-regex=system'
'--with-xml' '--with-expat-dir=/usr' '--with-zlib' '--with-layout=GNU'
'--enable-bcmath' '--enable-exif' '--enable-ftp' '--enable-magic-quotes'
'--enable-safe-mode' '--enable-sockets' '--enable-sysvsem'
'--enable-sysvshm' '--enable-discard-path' '--enable-track-vars'
'--enable-trans-sid' '--enable-yp' '--enable-wddx' '--without-oci8'
'--with-pear=/usr/share/pear' '--with-imap=shared' '--with-imap-ssl'
'--with-kerberos=/usr/kerberos' '--with-ldap=shared'
'--with-mysql=shared,/usr' '--with-pgsql=shared'
'--with-snmp=shared,/usr' '--with-snmp=shared' '--enable-ucd-snmp-hack'
'--with-unixODBC=shared' '--enable-memory-limit' '--enable-bcmath'
'--enable-shmop' '--enable-versioning' '--enable-calendar'
'--enable-dbx' '--enable-dio' '--enable-mcal' '--with-apxs2=/usr/sbin/apxs'

....and pasted it into a text file called conf

2. Downloaded php 5.0.2 source and unzipped it.

3. Copied the conf file to the same directory and made it executable.

4. Ran ./conf to run the configure command with the same options as the
current setup.

First question is, should this have worked?

Next, why doesn't it? The configure command seems to churn away happily
for a bit, then gets stuck with apxs.

"Sorry, I cannot run apxs. Possible reasons follow:

1. Perl is not installed
2. apxs was not found. Try to pass the path using --with-apxs2=/path/to/apxs
3. Apache was not built using --enable-so (the apxs usage page is displayed)

  follows:t of /usr/sbin/apxs
: No such file or directoryr/sbin/apxs
configure: error: Aborting
: command not found"

Now, to go through this...
1. Perl is installed and I'm able to run Perl script on the server.
whereis perl replies with /usr/bin/perl and this matches the #! line in
the apxs script.
2. As you can see from the configure options, the location of apxs is
specified and is correct.
3. Running httpd -l shows that mod_so.c was compiled in.

At this point, I run out of ideas. Any help would be greatly appreciated.



Re: apxs problem when updating PHP

On Sun, 26 Sep 2004 19:20:09 +0100, Derek Scollon

Quoted text here. Click to load it

 This bit looks a bit mangled; could you either confirm this is exactly how it
appears, or copy&paste it again?

Quoted text here. Click to load it

 What user are you running this as, and is /usr/sbin/apxs executable?

Quoted text here. Click to load it

<http://www.andyhsoftware.co.uk/space Space: disk usage analysis tool

Re: apxs problem when updating PHP

Andy Hassall wrote:

Quoted text here. Click to load it

Yes, that was exactly as it appeared. It looked strange to me too, as if
part of the message was being overwritten on the screen.

I'm running this as root and apxs is indeed executable (rwxr-xr-x).


Site Timeline