Apache 2.2.3 PHP 4.4.5 Install Fails

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!


I have Apache 2.2.3 installed and running on WinXP Pro SP2. I
installed PHP 4.4.5 and added the following lines in httpd.conf

PHPIniDir C:/PHP445/
LoadModule php4_module C:/PHP445/php4apache2.dll

When I restarted Apache, i got this error:

The Apache service reported the following error:
Quoted text here. Click to load it

Turns out that php4apache2.dll requires libapr.dll, libaprutil.dll and
libapriconv.dll to load. These are Apache dlls and are supposed to be
present in Apache2.2\bin folder. I did not find these dlls here.

I re-installed Apache 2.2.3 but the above mentioned libapr* dlls did
not get installed.

What else can I try?

Interestingly, php5apache2_2.dll from PHP 5.2 is not dependent on
above mentioned libapr* dlls and PHP 5.2 loads correctly. I must use
PHP 4.* however.


Site Timeline