adodb and M$ access databases

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Hi all,

I am using the Prade framework which includes a slightly
modified version von adodb 4.61 and I am working with M$
Access databases via OleDb (TAdodb is a wrapper class of
the ADODB ADOConnection class):

   $source = "Provider=Microsoft.Jet.OLEDB.4.0;".
             "Data Source=d:\temp\test.mdb";

   $this->connection = new TAdodb();
   $this->connection = &ADONewConnection('ado_access');

Although I have activated associative fetchmode I only
get field indices in my query results. Using SQLite as
database (which is unfortunately not an option for my
current project) it works as expected.

I have already searched Google, the phplens-forum and the
adodb mailing list, but haven't found anything useful.

Is this a known bug/feature of adodb?
Is there a solution for getting field names in the query

any help is appreciated - thanx in advance,

PS: I am working with PHP 5.03 under Windows 2000

PPS: xpost to alt.php and f'up to comp.lang.php

Re: adodb and M$ access databases

Quoted text here. Click to load it

Doubtful.  The reference page for ADOdb shows that SetFetchMode wants an
integer, not a string.  Try the constant ADODB_FETCH_ASSOC instead of
- Tim Roberts,
  Providenza & Boekelheide, Inc.

Re: adodb and M$ access databases

Tim Roberts wrote:
Quoted text here. Click to load it

Thanx for your answer - I have discovered this shortly after having
written my above message. But unfortunately it didn't change anything.


Site Timeline