When using system() to invoke lynx; connect_timeout ignored

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Hello All.

It has been my habit, for some time now , to use lynx; called through
the Perl system() command;  to grab web pages for processing. The  LWP
module would probably do a better job; yet old habits are hard to
break.  That said; my old habit is not doing the job for me at the
moment.  The call in the code is as follows:

system ("/bin/lynx -dump -source $url > $work_file2");

The /etc/lynx.cfg is set with:

# Specifies (in seconds) connect timeout. Not available under DOS (use
# sockdelay parameter of wattcp). Default value is rather huge.

Yet lynx does not seem to be timing out after 60 seconds.

My question is by using the system() command to summon lynx could that
be somehow overriding the connect_timeout setting?

Thanks for any help or insights in advance.

Site Timeline