Strange messages when using Net::SFTP

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!


we have some Perl scripts that do automatic ftp downloads and run on
windows workstations. For security reasons ftp services are going to be
deactivated in our network.

So I tried to use the Net::SFTP module with Perl 5.8.6 (ActiveState
build 811). As ActiveState does not provide ppms for this module I
first tried but this did not work
properly. Finally the ppms from
did the trick. The connect is as simple as

$sftp = Net::SFTP->new($host, user => $user, password => $password);

and a


provides a directory listing. But there is a strange side effect: On
STDERR I receive messages like

IO::Socket::INET at C:/Perl/site/lib/Net/SSH/Perl/ line 295
IO::String at C:/Perl/site/lib/Net/SSH/Perl/ line 110
IO::String at C:/Perl/site/lib/Net/SSH/Perl/ line 118

I looked at the corresponding lines but could find an explanation. Of
course I could just redirect STDERR but this is quite unsatisfying. How
can I get rid of these messages?

Regards, Michael

Site Timeline