QT Designer, puic, and kLed

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

I'm using QT Designer and puic to add a simple gui to a perl script.  Two
things are happening that I'm not sure about.  First, QT Designer
complains about the xml (.ui) file being the wrong version.  I have to
manually change the version in the .ui file from 3.3 to 3.2 for puic to
work.  When I run the .pl file I get the error "No method to call for :
Qt::Led(QGroupBox, 'kLed3') at mydialog.pl line 66."  Line 66 of the
script is:
     kLed3 = Qt::Led(groupBox1, "kLed3");

puic -version gives  PerlQt User Interface Compiler v0.70 for Qt version 3.3.1
KDE is 3.3.1, QT Designer is 3.3.1 and all the latest qt rpm's have been
installed from suse/supplementary/KDE.  I'm running SuSE 9.1 pro.

Any and all help is greatly appreciated.

Site Timeline