Problems with Perl 5.10 on Mac OS 10.5.2

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

This is a heads-up for Mac Perl users.

Yesterday I took the plunge and downloaded the Perl 5.10.0 source and
built it on my Mac Pro running OSX 10.5.2. I used all of the default
configuration parameters, except building for threads, for which I said

The build went OK, but 'make test' had one error in lib/locale.t,
something about a missing locale for test 99, which appears to be the
"C" locale.

I went ahead and did the install, anyway, since I am not too concerned
about locales. Everything looked fine, and I was able to update a CPAN
module that wasn't testing well under perl 5.10.

Today I ran the cpan shell to install a module and encountered the
following error:

jgibson 129% cpan
CPAN: File::HomeDir loaded ok (v0.65)
Can't locate Mac/ in @INC (@INC contains: /sw/lib/perl5
/sw/lib/perl5/darwin /Users/gibson/Library/Perl
/usr/local/lib/perl5/site_perl/5.8.8 /usr/local/lib/perl5/site_perl
/Users/gibson/Library/Perl/src/Mac-Carbon-0.77) at
/usr/local/lib/perl5/site_perl/5.8.8/File/HomeDir/ line 54.

The Mac::Files entry at CPAN points to:


I downloaded the tar file and tried to install with the "tar x;perl
Makefile.PL;make;make test;make install" sequence. "make test" fails on
AppleEvents/t/event with a "Too many arguments to AEBuildParameters()"

This looks like a 10.5.2 incompatibility. There are already 2 bugs
submitted to CPAN for what looks like this problem.

Has anybody else seen this problem? Is there a workaround? If not, I
will have to wait for the hopefully forthcoming fix. :(

Jim Gibson

 Posted Via Premium Usenet Newsgroup Services

Site Timeline