PPM sybperl not intended for MS2-x86-multi-thread

Do you have a question? Post it now! No Registration Necessary.  Now with pictures!

Threaded View
Can somebody pls shed some light on this rubbish Perl module business,
It has been driving me insane and i have now spent countless hours
trying to get it to work without any joy whatsoever.

I am using Perl build and I am having problems installing
the samn sybperl module. I have tried teh version in CPAn and it does
not work, I get the error stating that sys/types.h file or dir cannot
be found.

I then read somewhere that someobdy had this problem and got around it
using activeperl ppm v2, which is the one downloaded and trie dto use
and i am getting the error described below. Even when i try the manual
download from the pmm v2 on the activeperl site directory i still get
the same error!!!!

What am i doing wrong???????

Thanks, Sukhy  

PPM> install sybperl
Install package 'sybperl?' (y/N): y
Installing package 'sybperl'...
Error installing package 'sybperl': Read a PPD for 'sybperl', but it
is not intended for this build of Perl (MS2-x86-multi-thread)

Re: PPM sybperl not intended for MS2-x86-multi-thread

Quoted text here. Click to load it

It appears the module on CPAN needs to be compiled and you don't have all
the necessary files.

Quoted text here. Click to load it

This version of sybperl is for AS perl version 5.8 and you are using 5.6.1.
If you go to the ActiveState website and look at the modules, there is one
listed for perl 5.6 (Sybperl v2.13)


You can also upgrade to perl 5.8.


Re: PPM sybperl not intended for MS2-x86-multi-thread

Quoth sukhy666@xsmail.com (Sukhy Bahra):
Quoted text here. Click to load it

Cld yu spk Nglsh, pls?

Quoted text here. Click to load it

You have a C compiler? You cannot install XS modules directly from CPAN
without. If you do (you will need VC++ to use the module with AS perl)
then check you have the build environment set up properly. VC++ (IIRC)
comes with a little batch file to set some environment vars pointing to
where the headers/libs/etc are installed.

Quoted text here. Click to load it

You are attempting to install a PPM which is not compatible with your
version of Perl, as it told you.

Type perl -v at a command prompt, and go find a ppm for *that* version
of perl instead. Alternatively, find out what version of perl that ppm
is for (read the PPD file in a text editor) and install that. You may
have more luck that way round if AS only provide sybperl for 5.8 now:
5.6 is quite old.


And if you wanna make sense / Whatcha looking at me for?          (Fiona Apple)
                            * ben@morrow.me.uk *

Site Timeline